Georgia’s Virtual Library...bringing quality content to you!

GALILEO Help

Computer Configuration Instructions


Operating Systems | Browsers | Plug-ins


To achieve optimum performance within the GALILEO environment, the following computer and software configurations are recommended.

Operating Systems

The following computer operating systems are supported* by GALILEO:

PC

Macintosh

Mobile

** Not all distributions of Linux and Android have been tested for compatibility.

Top

Browsers

In general, GALILEO users should configure their browsers to enable JavaScript, to accept first-and third-party cookies, to avoid restrictively high browser security settings during GALILEO sessions, to disable pop-up blockers, and to check for new versions of cached pages regularly. The configuration instructions below provide more details on configuring GALILEO-compatible browsers for optimal performance.

GALILEO-Compatible Browsers

To achieve optimal performance within the GALILEO environment, please use one of the following supported* browsers:

Browser Configuration Instruction
Microsoft Internet Explorer version 11+, 8, 7, 6
Mozilla Firefox version 26+, 3, 2
Google Chrome version 32+
Apple Safari(Mac OS X) version 6.1+, 2.0

Top

Browser Configuration Instructions

Internet Explorer 11

To enable first- and third-party cookies:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “Privacy” tab.
  4. From the Privacy tab, drag the slider for the Privacy Settings to “Low.”
  5. Click “OK”
  6. Restart Internet Explorer.

To delete cookies:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “General” tab.
  4. In the “Browsing History” section, click “Delete.”
  5. Check the box beside “Cookies and website data.”
  6. Click “Delete.”
  7. Select “OK.”
  8. Restart Internet Explorer.
  9. If you do not want Internet Explorer to delete cookies each time you close the browser, follow these steps again and uncheck the box beside “Cookies and website data.”

To enable JavaScript:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “Security” tab and look at the Internet zone.
  4. Click “Custom Level.“
  5. In the Security Settings - Internet Zone window, click the checkbox to enable Active Scripting in the Scripting section (toward the bottom of the page)
  6. Click the OK button
  7. Restart Internet Explorer.

To configure security settings:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “Privacy” tab.
  4. From the Privacy tab, drag the slider for the Privacy Settings to “Low.”
  5. Click “OK”
  6. Restart Internet Explorer.

To add EBSCO as a trusted site and enable display of mixed content for Discover GALILEO:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “Security” tab
  4. Choose the Trusted Sites section (green check mark icon).
  5. Click the Sites button
  6. Uncheck Require server verification (https:) for all sites in this zone
  7. Type in *.ebscohost.com
  8. Click the Add button (you can now recheck the “Require server verification (https:) for all sites in this zone” box if you prefer to have this setting)
  9. Close the Trusted Sites window
  10. Click the Custom Level… button in the Trusted Sites section of the Security tab
  11. Scroll down to “Display Mixed Content”
  12. Select Enable
  13. Click the OK button for the Security Settings - Trusted Sites Zone
  14. Then, click the OK button for the Internet Options window
  15. You may need to close and reopen your browser for the settings to take effect

To configure cache settings:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “General” tab.
  4. Within the “Browsing History” area of the window, Click on “Settings.”
  5. Click “Automatically.”
  6. Click “OK.”
  7. Click “OK.”
  8. Restart Internet Explorer.

To delete browser cache:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “General” tab.
  4. In the “Browsing History” section, click “Delete.”
  5. Check the box beside “Temporary Internet files.”
  6. Click “Delete.”
  7. Select “OK.”
  8. Restart Internet Explorer.
  9. If you do not want Internet Explorer to delete the browser cache each time you close the browser, follow these steps again and uncheck the box beside“Temporary Internet files.”

To disable pop-up blocker:

  1. Click the icon that looks like a gear from the top-right of the screen.
  2. Select “Internet Options” from the drop-down menu.
  3. In the Internet Options dialog box, choose the “Privacy” tab.
  4. In the Pop-up Blocker section, uncheck the box that says “Turn on Pop-up Blocker.”
  5. To re-enable the pop-up blocker after completing a GALILEO session, select Gear Icon > Internet Options > Privacy tab > Pop-up Blocker > Check “Turn On Pop-up Blocker.”

These instructions are applicable only to the pop-up blocker in IE 11. IE users with other types of pop-up blockers, such as those provided by Internet service providers or in the Google and Yahoo toolbars, should consult the instructions provided with their specific pop-up blockers.

Top

Internet Explorer 8.0

To enable first- and third-party cookies:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “Privacy” tab.
  3. From the Privacy tab, drag the slider for the Privacy Settings to “Low.”
  4. Click “OK”
  5. Restart Internet Explorer.

To delete cookies:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “General” tab.
  3. In the “Browsing History” section, click “Delete.”
  4. Check the box beside “Cookies.”
  5. Click “Delete.”
  6. Select “OK.”
  7. Restart Internet Explorer.
  8. If you do not want Internet Explorer to delete cookies each time you close the browser, follow these steps again and uncheck the box beside “Cookies.”

To enable JavaScript:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “Security” tab and look at the Internet zone.
  3. Click “Custom Level.“
  4. In the Security Settings - Internet Zone window, click the checkbox to enable Active Scripting in the Scripting section (toward the bottom of the page)
  5. Click the OK button
  6. Restart Internet Explorer.

To configure security settings:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “Privacy” tab.
  3. From the Privacy tab, drag the slider for the Privacy Settings to “Low.”
  4. Click “OK”
  5. Restart Internet Explorer.

To add EBSCO as a trusted site and enable display of mixed content for Discover GALILEO:

  1. Go to Tools > Internet Options in Internet Explorer
  2. Choose the Security tab
  3. Choose the Trusted Sites section
  4. Click the Sites button
  5. Uncheck Require server verification (https:) for all sites in this zone
  6. Type in *.ebscohost.com
  7. Click the Add button (you can now recheck the “Require server verification (https:) for all sites in this zone” box if you prefer to have this setting)
  8. Close the Trusted Sites window
  9. Click the Custom Level… button in the Trusted Sites section of the Security tab
  10. Scroll down to “Display Mixed Content”
  11. Select Enable
  12. Click the OK button for the Security Settings - Trusted Sites Zone
  13. Then, click the OK button for the Internet Options window
  14. You may need to close and reopen your browser for the settings to take effect

To configure cache settings:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “General” tab.
  3. Within the “Browsing History” area of the window, Click on “Settings.”
  4. Click “Automatically.”
  5. Click “OK.”
  6. Click “OK.”
  7. Restart Internet Explorer.

To delete browser cache:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “General” tab.
  3. In the “Browsing History” section, click “Delete.”
  4. Check the box beside “Temporary Internet files.”
  5. Click “Delete.”
  6. Select “OK.”
  7. Restart Internet Explorer.
  8. If you do not want Internet Explorer to delete the browser cache each time you close the browser, follow these steps again and uncheck the box beside“Temporary Internet files.”

To disable pop-up blocker:

  1. Select “Tools” > “Pop-up Blocker” > “Turn off Pop-up Blocker.”
  2. To re-enable the pop-up blocker after completing a GALILEO session, select Tools > Pop-up Blocker > Turn On Pop-up Blocker.

These instructions are applicable only to the pop-up blocker in IE 8. IE users with other types of pop-up blockers, such as those provided by Internet service providers or in the Google and Yahoo toolbars, should consult the instructions provided with their specific pop-up blockers.

Top

Internet Explorer 7.0

To enable first- and third-party cookies:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “Privacy” tab.
  3. From the Privacy tab, drag the slider for the Privacy Settings to “Low.”
  4. Click “OK”
  5. Restart Internet Explorer.

To delete cookies:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “General” tab.
  3. In the “Browsing History” section, click “Delete.”
  4. In the “Cookies” section, click “Delete cookies.”
  5. Select “Yes.”
  6. Select “Close.”
  7. Select “OK.”
  8. Restart Internet Explorer.

To enable JavaScript:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “Security” tab and look at the Internet zone.
  3. Click “Custom Level.“
  4. In the Security Settings - Internet Zone window, click the checkbox to enable Active Scripting in the Scripting section (toward the bottom of the page)
  5. Click the OK button
  6. Restart Internet Explorer.

To configure security settings:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “Security” tab.
  3. Click “Default Level“ and then drag the slider to “Medium.”
  4. Click “OK.”
  5. Restart Internet Explorer.

To add EBSCO as a trusted site and enable display of mixed content for Discover GALILEO:

  1. Go to Tools > Internet Options in Internet Explorer
  2. Choose the Security tab
  3. Choose the Trusted Sites section
  4. Click the Sites button
  5. Uncheck Require server verification (https:) for all sites in this zone
  6. Type in *.ebscohost.com
  7. Click the Add button (you can now recheck the “Require server verification (https:) for all sites in this zone” box if you prefer to have this setting)
  8. Close the Trusted Sites window
  9. Click the Custom Level… button in the Trusted Sites section of the Security tab
  10. Scroll down to “Display Mixed Content”
  11. Select Enable
  12. Click the OK button for the Security Settings - Trusted Sites Zone
  13. Then, click the OK button for the Internet Options window
  14. You may need to close and reopen your browser for the settings to take effect

To configure cache settings:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “General” tab.
  3. Within the “Browsing History” area of the window, Click on “Settings.”
  4. Click “Automatically.”
  5. Click “OK.”
  6. Click “OK.”
  7. Restart Internet Explorer.

To delete browser cache:

  1. From the “Tools” menu, select “Internet Options.”
  2. In the Internet Options dialog box, choose the “General” tab.
  3. In the “Browsing History” section, click “Delete.”
  4. In the “Temporary Internet Files“ section, click “Delete files.”
  5. Select “Yes.”
  6. Select “Close.”
  7. Select “OK.”
  8. Restart Internet Explorer.

To disable pop-up blocker:

  1. Select “Tools” > “Pop-up Blocker” > “Turn off Pop-up Blocker.”
  2. To re-enable the pop-up blocker after completing a GALILEO session, select Tools > Pop-up Blocker > Turn On Pop-up Blocker.

These pop-up blocker instructions are applicable only to IE 7 users who have downloaded Windows XP Service Pack 2. IE users with other types of pop-up blockers, such as those provided by Internet service providers or in the Google and Yahoo toolbars, should consult the instructions provided with their specific pop-up blockers.

Internet Explorer 6.0 (This browser is no longer supported* by GALILEO)

Top

Firefox 26 and above

To enable first- and third-party cookies:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Privacy” tab.
  3. Set “Firefox will:” to “Remember history”.
  4. Click “OK.”
  5. Restart Firefox.

To delete cookies:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Privacy” tab. Set Firefox will: to Use custom settings for history.
  3. Click “Show Cookies”. The Cookies window will appear
  4. Click the “Remove All Cookies” button.
  5. Click the “Close” button.
  6. Click “OK.”
  7. Restart Firefox.

To configure security settings:

To configure cache settings:

To delete browser cache:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Privacy” tab.
  3. In the History area, click the clear your recent history link.
  4. In the Clear Recent History window that appears, set the Time range to clear: to Everything.
  5. In the list at the bottom of the window, uncheck everything except for Cache.
  6. Click on the Clear Now button.
  7. Click “OK.”
  8. Restart Firefox.

  9. Restart Firefox.

To disable pop-up blocker:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Content” tab.
  3. Uncheck the box next to “Block pop-up windows.”
  4. Click “OK.”
  5. Restart Firefox.

To enable JavaScript:

This option is no longer available in the Firefox interface. Please contact GALILEO using our Contact Us form for assistance.

Top

Firefox 3.0

To enable first- and third-party cookies:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Privacy” tab.
  3. Select the box corresponding to “Accept cookies from sites.”
  4. Click “OK.”
  5. Restart Firefox.

To delete cookies:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Privacy” tab.
  3. Click the “Show Cookies” button.
  4. Click the “Remove All Cookies” button.
  5. Click the “Close” button.
  6. Click “OK.”
  7. Restart Firefox.

To configure security settings:

To configure cache settings:

To delete browser cache:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Privacy” tab.
  3. Check the box beside “Clear history when Firefox closes.”
  4. Click the “Settings” button.
  5. Check the box beside “Cache.”
  6. Click “OK.”
  7. Click “OK” again.
  8. Restart Firefox.

To disable pop-up blocker:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Content” tab.
  3. Uncheck the box next to “Block pop-up windows.”
  4. Click “OK.”
  5. Restart Firefox.

To enable JavaScript:

  1. From the toolbar, select Tools > Options. (If you don’t see the Tools link at the top, click the orange Firefox button in the upper left and then choose Options > Options.)
  2. In the Options dialog box, choose the “Content” tab.
  3. Check the box next to “Enable JavaScript.”
  4. Click “OK.”
  5. Restart Firefox.

Top

Firefox 2.0

To enable first- and third-party cookies:

  1. From the toolbar, select Tools > Options.
  2. In the Options dialog box, choose the “Privacy” tab.
  3. Select the box corresponding to “Accept cookies from sites.”
  4. Click “OK.”
  5. Restart Firefox.

To delete cookies:

  1. From the toolbar, select Tools > Options.
  2. In the Options dialog box, choose the “Privacy” tab.
  3. In the bottom right, click the “Clear Now” button.
  4. Select “Cookies” from this list.
  5. Click the “Clear Private Data Now” button.
  6. Click “OK.”
  7. Restart Firefox.

To configure security settings:

To configure cache settings:

To delete browser cache:

  1. From the toolbar, select Tools > Options.
  2. In the Options dialog box, choose the “Privacy” tab.
  3. In the bottom right, click the “Clear Now” button.
  4. Select “Cache” from this list.
  5. Click the “Clear Private Data Now” button.
  6. Click “OK.”
  7. Restart Firefox.

To disable pop-up blocker:

  1. From the toolbar, select Tools > Options.
  2. In the Options dialog box, choose the “Content” tab.
  3. Uncheck the box next to “Block Popup Windows.”
  4. Click “OK.”
  5. Restart Firefox.

Top

Google Chrome

To enable first- and third-party cookies:

  1. Click the Customize and Control Google Chrome button (three horizontal bars in the upper right corner of the browser)
  2. Select Settings
  3. Scroll down and choose to Show advanced settings…
  4. Under the Privacy section, choose the Content settings… button
  5. Select Allow local data to be set (recommended)
  6. Click the OK button
  7. Restart Google Chrome

To delete cookies:

  1. Click the Customize and Control Google Chrome button (three horizontal bars in the upper right corner of the browser)
  2. Select Settings
  3. Scroll down and choose to Show advanced settings…
  4. Under the Privacy section, choose the Clear browsing data… button
  5. Select Delete cookies and other site and plug-in data
  6. In the Obliterate the following items from: dropdown, choose “the beginning of time”
  7. Click the Clear browsing data button at the bottom of the window

To enable JavaScript:

  1. Click the Customize and Control Google Chrome button (three horizontal bars in the upper right corner of the browser)
  2. Select Settings
  3. Scroll down and choose to Show advanced settings…
  4. Under the Privacy section, choose the Content settings… button
  5. Choose Allow all sites to run JavaScript (recommended)
  6. Click the OK button
  7. Restart Google Chrome

To delete browser cache:

  1. Click the Customize and Control Google Chrome button (three horizontal bars in the upper right corner of the browser)
  2. Select Settings
  3. Scroll down and choose to Show advanced settings…
  4. Under the Privacy section, choose the Clear browsing data… button
  5. Select Empty the cache
  6. In the Obliterate the following items from: dropdown, choose “the beginning of time”
  7. Click the Clear browsing data button at the bottom of the window

To disable pop-up blocker:

  1. Click the Customize and Control Google Chrome button (three horizontal bars in the upper right corner of the browser)
  2. Select Settings
  3. Scroll down and choose to Show advanced settings…
  4. Under the Privacy section, choose the Content settings… button
  5. Choose Allow all sites to show pop-ups (If you want to keep the Do not allow any site to show pop-ups (recommended) setting selected, you can click the Manage exceptions… button and add the domain of the website)
  6. Click the OK button
  7. Restart Google Chrome

Top

Apple Safari 6.1 (Mac OS X)

To enable first- and third-party cookies:

  1. From the toolbar, select Safari > Preferences
  2. Select the Security Tab.
  3. Click on “Always” to accept and remember all cookies.
  4. Restart Apple Safari.

To delete cookies:

  1. From the toolbar, select Safari > Preferences
  2. Select the Security Tab.
  3. Click “Details” button. a. To delete individual cookies, select individual cookie entries within the listing of cookies then click on the “Remove” button. b. To delete all cookies, select the “Remove All” button.
  4. Select “Done.”
  5. Restart Apple Safari.

To enable JavaScript:

  1. From the toolbar, click the Gear icon and choose Preferences
  2. Select the Security Tab.
  3. Check the box by Enable JavaScript.
  4. Restart Apple Safari.

To configure security settings:

To configure cache settings:

To delete cache:

  1. From the toolbar, select Safari > Reset Safari 2 You will be asked if you, “Are sure you want to reset the cache?”
  2. Select the items you want to reset (Remove all website data)
  3. Restart Apple Safari.

To disable pop-up blocker:

  1. From the toolbar, select Safari > Preferences a. A check mark by the Block Pop-up windows label indicates that pop-up blocking is enabled. Click on the label to turn off pop-up blocking. b. Restart Apple Safari.

Top

Apple Safari 2.0 (Mac OS X)

To enable first- and third-party cookies:

  1. From the toolbar, select Safari > Preferences
  2. Select the Security Tab.
  3. Click on “Always” to accept and remember all cookies.
  4. Restart Apple Safari.

To delete cookies:

  1. From the toolbar, select Safari > Preferences
  2. Select the Security Tab.
  3. Click “Show Cookies” button.
    1. To delete individual cookies, select individual cookie entries within the listing of cookies then click on the “Remove” button.
    2. To delete all cookies, select the “Remove All” button.
  4. Select “Done.”
  5. Restart Apple Safari.

To enable JavaScript:

  1. From the toolbar, click the Gear icon and choose Preferences
  2. Select the Security Tab.
  3. Check the box by Enable JavaScript.
  4. Restart Apple Safari.

To configure security settings:

To configure cache settings:

To delete cache:

  1. From the toolbar, select Safari > Empty Cache
    1. You will be asked if you, “Are sure you want to empty the cache?”
    2. Click “Empty.”
    3. Restart Apple Safari.

To disable pop-up blocker:

  1. From the toolbar, select Safari > Block Pop-up windows
    1. A check mark by the Block Pop-up windows label indicates that pop-up blocking is enabled. Click on the label to turn off pop-up blocking.
    2. Restart Apple Safari.

*Supported Operating Systems and Browsers: GALILEO will make every effort to ensure that new features, resources (databases), and services will work properly on supported operating systems and browsers by validation through testing and use of up-to-date and standard coding and design practices.

Top

Recommended Software Plug-ins

GALILEO includes many databases that feature different types of multimedia and document file types. In order to view full text PDF articles and see and hear a variety of audio, video, and image files, a number of software plug-ins are recommended. If these plug-ins are not already installed on your computer, use the links provided to download them.

* Internet Explorer users may encounter problems with the DjVu and MrSID plug-ins if ActiveX is disabled in their browser settings. If you encounter problems with DjVu and MrSID images, follow these steps to enable ActiveX in Internet Explorer:

  1. From the toolbar, select Tools > Internet Options.
  2. In the Internet Options dialog box, choose the “Security“ tab.
  3. Click the “Custom Level” button.
  4. Under the “ActiveX controls and plug-ins” heading in the Security Settings panel, enable the “Download signed ActiveX controls,” “Run ActiveX controls and plug-ins,” and “Script ActiveX controls marked safe for scripting” options.
  5. Click “OK” in the Security Settings panel, then click “OK” in the Internet Options panel.

Top